Commandes Linux : apt-show-versions

APT-SHOW-VERSIONS

Installé avec le paquet apt-show-verions
Voir aussi : apt et aptitude
 

Afficher la version de la commande apt-show-versions

apt-cache policy apt-show-versions

 

Options utiles

    -u : filtre la recherche aux paquets upgradables
    -a : affiche toutes les versions disponibles

 

Afficher la liste des paquets installés

apt-show-versions

Les paquets installés seront listés, et ceux nécessitant une mise à jour seront spécifiés.
Si plusieurs publications/branches ont été déclarées, alors les mises à jour correspondantes seront signifiées.
Equivaut à :
apt list --installed
ex :

# apt-show-versions
[...]
telepathy-salut:i386/jessie 0.8.1-4 uptodate
telnet:i386/jessie 0.17-36 uptodate
terminator:all/jessie 0.97-4 uptodate
texinfo:i386/jessie 5.2.0.dfsg.1-6 uptodate
time:i386/jessie 1.7-25 uptodate
[...]

Filtrage par paquet :

apt-show-versions package

 

Afficher uniquement la liste des paquets pouvant être mis à jour

apt-show-versions -u

Cette commande filtre le résultat de la première en se limitant aux paquets disposant d’une mise à jour.
Equivaut à :
apt list --upgradable
ex :

# apt-show-versions -u
[...]
uno-libs3:i386/jessie 4.3.3-2+deb8u4 upgradeable to 4.3.3-2+deb8u5
ure:i386/jessie 4.3.3-2+deb8u4 upgradeable to 4.3.3-2+deb8u5
wget:i386/jessie 1.16-1 upgradeable to 1.16-1+deb8u1
wpasupplicant:i386/jessie 2.3-1+deb8u3 upgradeable to 2.3-1+deb8u4
[...]

Filtrage par paquet :

apt-show-versions -u package

 

Afficher toutes les versions disponibles d’un paquet

apt-show-versions -a package

Si plusieurs publications/branches ont été déclarées, alors les versions et mises à jour correspondantes seront signifiées.
Proche de :
apt-cache madison package
apt-cache policy package
aptitude versions package
apt list --all-versions package
ex :

# apt-show-versions -a wget
wget:i386 1.16-1 install ok installed
wget:i386 1.16-1+deb8u1 jessie   ftp.fr.debian.org
No stable-updates version
wget:i386 1.18-3        unstable ftp.fr.debian.org
wget:i386/unstable 1.16-1 upgradeable to 1.18-3
# apt-show-versions -a terminator
terminator:all 0.97-4 install ok installed
terminator:all 0.97-4 jessie ftp.fr.debian.org
No stable-updates version
terminator:all/jessie 0.97-4 uptodate
Fermer le menu
%d blogueurs aiment cette page :